GoTheDistance

ござ先輩と言われています。(株) クオリティスタートという会社をやっています。

やってくれるぜDB2

DB2ってDB2クライアントとUDB本体の間に下位互換性がないという罠。

つまり、

Client:ver7⇔UDB:ver8はOK。
Client:ver8⇔UDB:ver7がNG。

ということ。

一説によるとDB27.2の最新のFixpackと、DB2クライアントVer8.2の最新のFixpackの組み合わせならばいけるらしい。下位互換性を確保できたのが最近とは。7.xシリーズってもうサポート切れてるのもあったりするのにのぅ。